build: move imgui out of src/intel/tools to be reused
[mesa.git] / src / imgui / meson.build
diff --git a/src/imgui/meson.build b/src/imgui/meson.build
new file mode 100644 (file)
index 0000000..a5c0283
--- /dev/null
@@ -0,0 +1,11 @@
+libimgui_core = static_library(
+  'intel_imgui_core',
+  files('imgui.cpp', 'imgui_demo.cpp', 'imgui_draw.cpp'),
+  cpp_args : ['-w'],
+  install: false
+)
+
+libimgui_core_dep = declare_dependency(
+  link_with: libimgui_core,
+  include_directories: include_directories('.')
+)