meson: Use consistent style for tests
[mesa.git] / src / intel / isl / meson.build
index 47fd8d97c32e9ae5d5cecebff743f7e485e3ca9f..116750d86d6659298a7fbf0d6f5c034567356c2a 100644 (file)
@@ -90,13 +90,14 @@ libisl = static_library(
 )
 
 if with_tests
-  isl_surf_get_image_offset_test = executable(
-    'isl_surf_get_image_offset_test',
-    'tests/isl_surf_get_image_offset_test.c',
-    dependencies : dep_m,
-    include_directories : [inc_common, inc_intel],
-    link_with : [libisl, libintel_common],
+  test(
+    'isl_surf_get_image_offset',
+    executable(
+      'isl_surf_get_image_offset_test',
+      'tests/isl_surf_get_image_offset_test.c',
+      dependencies : dep_m,
+      include_directories : [inc_common, inc_intel],
+      link_with : [libisl, libintel_common],
+    )
   )
-
-  test('isl_surf_get_image_offset', isl_surf_get_image_offset_test)
 endif