meson: move the generic symbols check arguments to a common variable
[mesa.git] / src / intel / vulkan / meson.build
index 69e472f719b80a286d3058030f685c0984836c09..c21d7bd25074bc7305ca3bcf41ff8ac8c658d657 100644 (file)
@@ -133,6 +133,7 @@ anv_deps = [
   dep_valgrind,
   idep_nir_headers,
   idep_vulkan_util_headers,
+  idep_xmlconfig_headers,
 ]
 anv_flags = [
   c_vis_args,
@@ -206,14 +207,14 @@ libvulkan_intel = shared_library(
   install : true,
 )
 
-if with_tests and prog_nm.found()
+if with_symbols_check
   test(
     'anv symbols check',
     symbols_check,
     args : [
       '--lib', libvulkan_intel,
       '--symbols-file', vulkan_icd_symbols,
-      '--nm', prog_nm.path(),
+      symbols_check_args,
     ],
     suite : ['intel'],
   )