At this commit driver skeleton is able to dump spirv and nir
[mesa.git] / src / libre-soc / vulkan / meson.build
index 1c4e84314c826c55f5dddc6327aa7cc377e2f54c..e6f64a80d253e0f23f3b13d133b3c0b3c6ddf199 100644 (file)
@@ -51,26 +51,6 @@ libresoc_entrypoints = custom_target(
     ],
   depend_files : files('libresoc_extensions.py'),
   )
-#libresoc_entrypoints = custom_target(
-#  'libresoc_entrypoints.[ch]',
-#  input : ['libresoc_entrypoints_gen.py', vk_api_xml],
-#  output : ['libresoc_entrypoints.h', 'libresoc_entrypoints.c'],
-#  command : [
-#    prog_python, '@INPUT0@', '--xml', '@INPUT1@', '--outdir',
-#    meson.current_build_dir()
-#  ],
-#  depend_files : files('libresoc_extensions.py'),
-#)
-#
-#libresoc_extensions_c = custom_target(
-#  'libresoc_extensions.c',
-#  input : ['libresoc_extensions.py', vk_api_xml],
-#  output : ['libresoc_extensions.c', 'libresoc_extensions.h'],
-#  command : [
-#    prog_python, '@INPUT0@', '--xml', '@INPUT1@', '--out-c', '@OUTPUT0@',
-#    '--out-h', '@OUTPUT1@'
-#  ],
-#)
 
 libresoc_vk_format_table_c = custom_target(
   'libresoc_vk_format_table.c',
@@ -83,59 +63,48 @@ libresoc_vk_format_table_c = custom_target(
 
 liblibresoc_files = files(
   'libresoc_device.c',
+  'libresoc_debug.c',
+  'libresoc_shader.c',
+  'libresoc_descriptor_set.c',
+  'libresoc_pass.c',
+  'libresoc_meta_clear.c',
+  'libresoc_image.c',
+  'libresoc_cmd_buffer.c',
+  'libresoc_formats.c',
   'libresoc_pipeline.c',
   'libresoc_pipeline_cache.c',
   'libresoc_util.c',
+  'libresoc_wsi.c',
+  'libresoc_private.h',
+  'vk_format.h',
 )
 
 libresoc_deps = []
 libresoc_flags = []
-
 libresoc_flags += '-DVK_USE_PLATFORM_DISPLAY_KHR'
+libresoc_flags += '-DVK_USE_PLATFORM_XLIB_KHR'
+libresoc_flags += '-DVK_USE_PLATFORM_XCB_KHR'
 if with_platform_x11
-  #libresoc_deps += dep_xcb_dri3
-  #libresoc_flags += [
-  #  '-DVK_USE_PLATFORM_XCB_KHR',
-  #  '-DVK_USE_PLATFORM_XLIB_KHR',
-  #]
-  #liblibresoc_files += files('libresoc_wsi_x11.c')
-endif
-
-if with_platform_wayland
-  #libresoc_deps += dep_wayland_client
-  #libresoc_flags += '-DVK_USE_PLATFORM_WAYLAND_KHR'
-  #liblibresoc_files += files('libresoc_wsi_wayland.c')
-endif
-
-if system_has_kms_drm and not with_platform_android
-  #libresoc_flags += '-DVK_USE_PLATFORM_DISPLAY_KHR'
-  #liblibresoc_files += files('libresoc_wsi_display.c')
-endif
-
-if with_xlib_lease
-  #libresoc_deps += [dep_xcb_xrandr, dep_xlib_xrandr]
-  #libresoc_flags += '-DVK_USE_PLATFORM_XLIB_XRANDR_EXT'
-endif
-
-if with_platform_android
-  #libresoc_deps += dep_android
-  #libresoc_flags += [
-  #  '-DVK_USE_PLATFORM_ANDROID_KHR'
-  #]
+ libresoc_deps += dep_xcb_dri3
+ libresoc_flags += [
+   '-DVK_USE_PLATFORM_XCB_KHR',
+   '-DVK_USE_PLATFORM_XLIB_KHR',
+ ]
+ liblibresoc_files += files('libresoc_wsi_x11.c')
 endif
 
 libvulkan_libresoc = shared_library(
   'vulkan_libresoc',
   [liblibresoc_files, libresoc_entrypoints, libresoc_extensions_c, libresoc_extensions_h, libresoc_vk_format_table_c, sha1_h],
   include_directories : [
-    inc_include, inc_src, inc_mapi, inc_mesa,  inc_compiler, inc_util, inc_vulkan_wsi, #inc_gallium, inc_gallium_aux, inc_amd, inc_amd_common, inc_amd_common_llvm,
+    inc_include, inc_src, inc_mapi, inc_mesa,  inc_compiler, inc_util, inc_vulkan_wsi, inc_gallium_aux, inc_gallium, #inc_amd, inc_amd_common, inc_amd_common_llvm,
   ],
   link_with : [
     libvulkan_wsi, #libamd_common, libamd_common_llvm, libamdgpu_addrlib, 
   ],
   dependencies : [idep_vulkan_util, libresoc_deps,idep_xmlconfig, dep_libdrm,
         dep_llvm, dep_thread, dep_elf, dep_dl, dep_m,dep_valgrind, idep_mesautil, idep_nir,
-    # libresoc_deps, idep_aco, dep_libdrm_amdgpu,
+     libresoc_deps, #idep_aco, dep_libdrm_amdgpu,
     #  idep_amdgfxregs_h, 
   ],
   c_args : [no_override_init_args, libresoc_flags],