loader: replace xmlpool_options_h with idep_xmlconfig_headers
[mesa.git] / src / loader / meson.build
index 425620372aae23470c517c1f0bc878b4aede3cdf..00ba1491c45da0b1c1befd64c686ae7c3102d4c9 100644 (file)
@@ -23,10 +23,12 @@ inc_loader = include_directories('.')
 if with_platform_x11 and with_dri3
   libloader_dri3_helper = static_library(
     'loader_dri3_helper',
-    ['loader_dri3_helper.c', 'loader_dri3_helper.h'],
+    'loader_dri3_helper.c',
     c_args : c_vis_args,
-    include_directories : inc_include,
-    dependencies : [dep_xcb_dri3, dep_libdrm],
+    include_directories : [inc_include, inc_src],
+    dependencies : [
+      dep_libdrm, dep_xcb_dri3, dep_xcb_present, dep_xcb_sync, dep_xshmfence,
+    ],
     build_by_default : false,
   )
 else
@@ -35,10 +37,11 @@ endif
 
 libloader = static_library(
   'loader',
-  ['loader.c', 'loader.h', 'pci_id_driver_map.c', 'pci_id_driver_map.h',
-   xmlpool_options_h],
-  c_args : [c_vis_args, '-DUSE_DRICONF'],
+  ['loader.c', 'pci_id_driver_map.c'],
+  c_args : [c_vis_args, '-DUSE_DRICONF',
+            '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_search_path),
+],
   include_directories : [inc_include, inc_src, inc_util],
-  dependencies : dep_libdrm,
+  dependencies : [dep_libdrm, dep_thread, idep_xmlconfig_headers],
   build_by_default : false,
 )