meson/loader: drop unneeded *.h file
[mesa.git] / src / loader / meson.build
index 69c81688bf4156ee17e71f95bbbbd49eca951a5a..9d5a7968af4f6f8fa8a81d6b8e51c1164d264525 100644 (file)
@@ -23,7 +23,7 @@ inc_loader = include_directories('.')
 if with_platform_x11 and with_dri3
   libloader_dri3_helper = static_library(
     'loader_dri3_helper',
-    ['loader_dri3_helper.c', 'loader_dri3_helper.h'],
+    'loader_dri3_helper.c',
     c_args : c_vis_args,
     include_directories : [inc_include, inc_src],
     dependencies : [
@@ -37,8 +37,7 @@ endif
 
 libloader = static_library(
   'loader',
-  ['loader.c', 'loader.h', 'pci_id_driver_map.c', 'pci_id_driver_map.h',
-   xmlpool_options_h],
+  ['loader.c', 'pci_id_driver_map.c', xmlpool_options_h],
   c_args : [c_vis_args, '-DUSE_DRICONF',
             '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_search_path),
 ],