meson: move the generic symbols check arguments to a common variable
[mesa.git] / src / mapi / es1api / meson.build
index 9d97dd67c40d95796b6b29e09b4974db8a983f3e..711048421b80288664b96839e7fbc117582e5623 100644 (file)
@@ -62,14 +62,14 @@ pkg.generate(
   libraries_private : gl_priv_libs,
 )
 
-if with_tests and prog_nm.found()
+if with_symbols_check
   test(
     'es1-ABI-check',
     symbols_check,
     args : [
       '--lib', libglesv1_cm,
       '--symbols-file', files('gles1-symbols.txt'),
-      '--nm', prog_nm.path(),
+      symbols_check_args,
     ],
     suite : ['mapi'],
   )