meson: move the generic symbols check arguments to a common variable
[mesa.git] / src / mapi / es1api / meson.build
index d8a77a41df2ccf71aba651735885f9e28ad8e391..711048421b80288664b96839e7fbc117582e5623 100644 (file)
 
 es1_glapi_mapi_tmp_h = custom_target(
   'es1_glapi_mapi_tmp.h',
-  input : [mapi_abi_py, gl_and_es_api_files],
+  input : [glapi_gen_mapi_py, glapi_gen_gl_xml],
   output : 'glapi_mapi_tmp.h',
-  command : [prog_python, '@INPUT0@', '--printer', 'es1api', '@INPUT1@'],
-  depend_files : api_xml_files,
+  command : [prog_python, '@INPUT0@', 'glesv1', '@INPUT1@'],
+  depend_files : glapi_gen_mapi_deps,
   capture : true,
 )
 
+_es1_c_args = []
+if with_platform_windows
+  _es1_c_args += ['-D_GDI32_', '-DBUILD_GL32']
+endif
+
 libglesv1_cm = shared_library(
-  'GLESv1_CM',
+  'GLESv1_CM' + get_option('gles-lib-suffix'),
   ['../entry.c', es1_glapi_mapi_tmp_h],
   c_args : [
-    c_msvc_compat_args, c_vis_args, '-DMAPI_MODE_BRIDGE',
+    c_msvc_compat_args,
+    c_vis_args,
+    _es1_c_args,
+    '-DMAPI_MODE_BRIDGE',
     '-DMAPI_ABI_HEADER="@0@"'.format(es1_glapi_mapi_tmp_h.full_path()),
+    gcc_lto_quirk,
   ],
   link_args : [ld_args_gc_sections],
   include_directories : [inc_src, inc_include, inc_mapi],
   link_with : libglapi,
   dependencies : [dep_thread, dep_libdrm, dep_m, dep_dl],
-  version : '1.0.0',
+  soversion : host_machine.system() == 'windows' ? '' : '1',
+  version : '1.1.0',
+  name_prefix : 'lib',
   install : true,
 )
 
@@ -51,11 +62,15 @@ pkg.generate(
   libraries_private : gl_priv_libs,
 )
 
-if with_tests
+if with_symbols_check
   test(
     'es1-ABI-check',
-    find_program('ABI-check'),
-    env : env_test,
-    args : libglesv1_cm
+    symbols_check,
+    args : [
+      '--lib', libglesv1_cm,
+      '--symbols-file', files('gles1-symbols.txt'),
+      symbols_check_args,
+    ],
+    suite : ['mapi'],
   )
 endif