meson: Build with Python 3
[mesa.git] / src / mapi / glapi / gen / meson.build
index a6a93cc83bea0bf2a0514dfeb30d9c29040e2e71..b148627f712d21efe2bcb563d6b222e113b1338e 100644 (file)
@@ -149,7 +149,7 @@ glapi_mapi_tmp_h = custom_target(
   'glapi_mapi_tmp.h',
   input : [mapi_abi_py, 'gl_and_es_API.xml'],
   output : 'glapi_mapi_tmp.h',
-  command : [prog_python2, '@INPUT0@', '--printer', 'glapi', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '--printer', 'glapi', '@INPUT1@'],
   depend_files : glapi_gen_depends,
   capture : true,
 )
@@ -158,7 +158,7 @@ glprocs_h = custom_target(
   'glprocs.h',
   input : ['gl_procs.py', 'gl_and_es_API.xml'],
   output : 'glprocs.h',
-  command : [prog_python2, '@INPUT0@', '-c', '-f', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '-c', '-f', '@INPUT1@'],
   depend_files : glapi_gen_depends,
   capture : true,
 )
@@ -167,7 +167,7 @@ glapitemp_h = custom_target(
   'glapitemp.h',
   input : ['gl_apitemp.py', 'gl_and_es_API.xml'],
   output : 'glapitemp.h',
-  command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '-f', '@INPUT1@'],
   depend_files : glapi_gen_depends,
   capture : true,
 )
@@ -176,7 +176,7 @@ glapitable_h = custom_target(
   'glapitable.h',
   input : ['gl_table.py', 'gl_and_es_API.xml'],
   output : 'glapitable.h',
-  command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '-f', '@INPUT1@'],
   depend_files : glapi_gen_depends,
   capture : true,
 )
@@ -185,7 +185,7 @@ glapi_gentable_c = custom_target(
   'glapi_gentable.c',
   input : ['gl_gentable.py', 'gl_and_es_API.xml'],
   output : 'glapi_gentable.c',
-  command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '-f', '@INPUT1@'],
   depend_files : glapi_gen_depends,
   capture : true,
 )
@@ -194,7 +194,7 @@ main_enums_c = custom_target(
   'enums.c',
   input : ['gl_enums.py', files('../registry/gl.xml')],
   output : 'enums.c',
-  command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '-f', '@INPUT1@'],
   capture : true,
 )
 
@@ -202,7 +202,7 @@ main_api_exec_c = custom_target(
   'api_exec.c',
   input : ['gl_genexec.py', 'gl_and_es_API.xml'],
   output : 'api_exec.c',
-  command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '-f', '@INPUT1@'],
   depend_files : files('apiexec.py') + glapi_gen_depends,
   capture : true,
 )
@@ -211,7 +211,7 @@ main_marshal_generated_c = custom_target(
   'marshal_generated.c',
   input : ['gl_marshal.py', 'gl_and_es_API.xml'],
   output : 'marshal_generated.c',
-  command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '-f', '@INPUT1@'],
   depend_files : files('marshal_XML.py') + glapi_gen_depends,
   capture : true,
 )
@@ -223,7 +223,7 @@ foreach x : [['indirect.c', 'proto'], ['indirect.h', 'init_h'], ['indirect_init.
     x[0],
     input : ['glX_proto_send.py', 'gl_API.xml'],
     output : x[0],
-    command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@', '-m', x[1]],
+    command : [prog_python, '@INPUT0@', '-f', '@INPUT1@', '-m', x[1]],
     depend_files : glx_gen_depends,
     capture : true,
   )
@@ -235,7 +235,7 @@ foreach x : [['indirect_size.h', ['-m', 'size_h', '--header-tag', '_INDIRECT_SIZ
     x[0],
     input : ['glX_proto_size.py', 'gl_API.xml'],
     output : x[0],
-    command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@', '--only-set', x[1]],
+    command : [prog_python, '@INPUT0@', '-f', '@INPUT1@', '--only-set', x[1]],
     depend_files : glx_gen_depends,
     capture : true,
   )
@@ -246,7 +246,7 @@ glapi_x86_s = custom_target(
   'glapi_x86.S',
   input : ['gl_x86_asm.py', gl_and_es_api_files],
   output : 'glapi_x86.S',
-  command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '-f', '@INPUT1@'],
   depend_files : glapi_gen_depends,
   capture : true,
 )
@@ -255,7 +255,7 @@ glapi_x86_64_s = custom_target(
   'glapi_x86-64.S',
   input : ['gl_x86-64_asm.py', gl_and_es_api_files],
   output : 'glapi_x86-64.S',
-  command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '-f', '@INPUT1@'],
   depend_files : glapi_gen_depends,
   capture : true,
 )
@@ -264,7 +264,7 @@ glapi_sparc_s = custom_target(
   'glapi_sparc.S',
   input : ['gl_SPARC_asm.py', gl_and_es_api_files],
   output : 'glapi_sparc.S',
-  command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '-f', '@INPUT1@'],
   depend_files : glapi_gen_depends,
   capture : true,
 )