Added few more stubs so that control reaches to DestroyDevice().
[mesa.git] / src / mapi / meson.build
index 24013c6554270047b989d81a626fe0f3bc4d1c77..2c79a04f1df2dbaf3851540ef0830ee884d18203 100644 (file)
@@ -26,15 +26,20 @@ files_mapi_util = files(
 )
 
 genCommon_py = files('new/genCommon.py')
+glapi_gen_mapi_py = files('new/gen_gldispatch_mapi.py')
 mapi_abi_py = files('mapi_abi.py')
 
 subdir('glapi')
 if with_shared_glapi
   subdir('shared-glapi')
+else
+  libglapi = []
 endif
-if with_gles1
-  subdir('es1api')
-endif
-if with_gles2
-  subdir('es2api')
+if not with_glvnd
+  if with_gles1
+    subdir('es1api')
+  endif
+  if with_gles2
+    subdir('es2api')
+  endif
 endif