meson: move the generic symbols check arguments to a common variable
[mesa.git] / src / mapi / meson.build
index 3e79bbaa7aa06f8a34303b746f3dbe0dd2b9624a..2c79a04f1df2dbaf3851540ef0830ee884d18203 100644 (file)
@@ -32,10 +32,14 @@ mapi_abi_py = files('mapi_abi.py')
 subdir('glapi')
 if with_shared_glapi
   subdir('shared-glapi')
+else
+  libglapi = []
 endif
-if with_gles1
-  subdir('es1api')
-endif
-if with_gles2
-  subdir('es2api')
+if not with_glvnd
+  if with_gles1
+    subdir('es1api')
+  endif
+  if with_gles2
+    subdir('es2api')
+  endif
 endif