Added few more stubs so that control reaches to DestroyDevice().
[mesa.git] / src / mapi / meson.build
index ce94ee4b27a956380617907a5a6d1b37bca7fa58..2c79a04f1df2dbaf3851540ef0830ee884d18203 100644 (file)
@@ -25,13 +25,21 @@ files_mapi_util = files(
   'u_execmem.h',
 )
 
+genCommon_py = files('new/genCommon.py')
+glapi_gen_mapi_py = files('new/gen_gldispatch_mapi.py')
+mapi_abi_py = files('mapi_abi.py')
+
+subdir('glapi')
 if with_shared_glapi
   subdir('shared-glapi')
+else
+  libglapi = []
 endif
-subdir('glapi')
-if with_gles1
-  subdir('es1api')
-endif
-if with_gles2
-  subdir('es2api')
+if not with_glvnd
+  if with_gles1
+    subdir('es1api')
+  endif
+  if with_gles2
+    subdir('es2api')
+  endif
 endif