meson: re-add incorrect pkg-config files with GLVND for backward compatibility
[mesa.git] / src / mapi / meson.build
index 3e79bbaa7aa06f8a34303b746f3dbe0dd2b9624a..39c1dba7ce0318d968f45899a8ec927e5d8f257c 100644 (file)
@@ -32,10 +32,14 @@ mapi_abi_py = files('mapi_abi.py')
 subdir('glapi')
 if with_shared_glapi
   subdir('shared-glapi')
+else
+  libglapi = []
 endif
-if with_gles1
-  subdir('es1api')
-endif
-if with_gles2
-  subdir('es2api')
+if not with_glvnd or glvnd_missing_pc_files
+  if with_gles1
+    subdir('es1api')
+  endif
+  if with_gles2
+    subdir('es2api')
+  endif
 endif