mapi: add shared glapi symbols check
[mesa.git] / src / mapi / shared-glapi / meson.build
index af0c68a1c838089aead9578f17d66edd32226e28..1847e17383b3b7504b70dd926ce4425d2ad69824 100644 (file)
@@ -64,4 +64,16 @@ if with_any_opengl and with_tests
     ),
     suite : ['mapi'],
   )
+  if prog_nm.found()
+    test(
+      'shared-glapi symbols check',
+      symbols_check,
+      args : [
+        '--lib', libglapi,
+        '--symbols-file', files('glapi-symbols.txt'),
+        '--nm', prog_nm.path(),
+      ],
+      suite : ['mapi'],
+    )
+  endif
 endif