meson: move the generic symbols check arguments to a common variable
[mesa.git] / src / mapi / shared-glapi / meson.build
index 7d0fe115d63f92d6834830d07cf559b026934d81..5b9db0c081a90acf6f5d6740492c23ca6899141b 100644 (file)
@@ -74,14 +74,14 @@ if with_any_opengl and with_tests
     ),
     suite : ['mapi'],
   )
-  if prog_nm.found()
+  if with_symbols_check
     test(
       'shared-glapi symbols check',
       symbols_check,
       args : [
         '--lib', libglapi,
         '--symbols-file', files('glapi-symbols.txt'),
-        '--nm', prog_nm.path(),
+        symbols_check_args,
       ],
       suite : ['mapi'],
     )