meson: move the generic symbols check arguments to a common variable
[mesa.git] / src / mapi / shared-glapi / meson.build
index dcc6079af3d6eee9928e7ae8137d862f06bbe6ac..5b9db0c081a90acf6f5d6740492c23ca6899141b 100644 (file)
@@ -36,17 +36,28 @@ shared_glapi_mapi_tmp_h = custom_target(
   capture : true,
 )
 
+_glapi_c_args = []
+if with_platform_windows
+  _glapi_c_args += ['-D_GLAPI_DLL_EXPORTS']
+endif
+
 libglapi = shared_library(
   'glapi',
   [files_mapi_glapi, files_mapi_util, shared_glapi_mapi_tmp_h],
   c_args : [
-    c_msvc_compat_args, '-DMAPI_MODE_GLAPI',
+    _glapi_c_args,
+    c_msvc_compat_args,
+    c_vis_args,
+    '-DMAPI_MODE_GLAPI',
     '-DMAPI_ABI_HEADER="@0@"'.format(shared_glapi_mapi_tmp_h.full_path()),
+    gcc_lto_quirk,
   ],
   link_args : [ld_args_gc_sections],
   include_directories : [inc_src, inc_include, inc_mapi],
   dependencies : [dep_thread, dep_selinux],
+  soversion : host_machine.system() == 'windows' ? '' : '0',
   version : '0.0.0',
+  name_prefix : 'lib',
   install : true,
 )
 
@@ -60,6 +71,19 @@ if with_any_opengl and with_tests
       include_directories : [inc_src, inc_include, inc_mapi],
       link_with : [libglapi],
       dependencies : [dep_thread, idep_gtest],
-    )
+    ),
+    suite : ['mapi'],
   )
+  if with_symbols_check
+    test(
+      'shared-glapi symbols check',
+      symbols_check,
+      args : [
+        '--lib', libglapi,
+        '--symbols-file', files('glapi-symbols.txt'),
+        symbols_check_args,
+      ],
+      suite : ['mapi'],
+    )
+  endif
 endif