build: Fix out-of-tree generation of api_exec_es{1,2}.c
[mesa.git] / src / mesa / Makefile.am
index 85cdc1a6559801e8da594515c63cb9159eee7fca..1049ad49d80ea682c0d8740536f2a8fbb20e2cee 100644 (file)
@@ -77,11 +77,11 @@ main/api_exec_es2_remap_helper.h: $(GLAPI)/gl_and_es_API.xml $(glapi_gen_remap_d
 main/api_exec_es2.o: main/api_exec_es2_dispatch.h main/api_exec_es2_remap_helper.h
 
 main/api_exec_es1.c: main/APIspec.xml main/es_generator.py main/APIspecutil.py main/APIspec.py
-       $(PYTHON2) $(PYTHON_FLAGS) main/es_generator.py \
+       $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/main/es_generator.py \
          -S $(srcdir)/main/APIspec.xml -V GLES1.1 > $@
 
 main/api_exec_es2.c: main/APIspec.xml main/es_generator.py main/APIspecutil.py main/APIspec.py
-       $(PYTHON2) $(PYTHON_FLAGS) main/es_generator.py \
+       $(PYTHON2) $(PYTHON_FLAGS) $(srcdir)/main/es_generator.py \
          -S $(srcdir)/main/APIspec.xml -V GLES2.0 > $@
 
 program/program_parse.tab.c program/program_parse.tab.h: program/program_parse.y