autotools: include meson build files in tarball
[mesa.git] / src / mesa / drivers / dri / Makefile.am
index 08a8e6455219da5b9cf53557d83fc4143aed9331..ae30996e028e9dd0c1b1e41286a80227c40c9083 100644 (file)
@@ -52,19 +52,28 @@ driinclude_HEADERS = \
 nodist_EXTRA_mesa_dri_drivers_la_SOURCES = dummy.cpp
 mesa_dri_drivers_la_SOURCES =
 mesa_dri_drivers_la_LDFLAGS = \
-        -module -avoid-version -shared -shrext .so \
-        $(BSYMBOLIC) \
-        $(GC_SECTIONS) \
-        $()
+       -shared \
+       -shrext .so \
+       -module \
+       -no-undefined \
+       -avoid-version \
+       -Wl,--build-id=sha1 \
+       $(BSYMBOLIC) \
+       $(GC_SECTIONS) \
+       $(LD_NO_UNDEFINED)
+
 mesa_dri_drivers_la_LIBADD = \
         ../../libmesa.la \
         common/libmegadriver_stub.la \
         common/libdricommon.la \
-        common/libxmlconfig.la \
+        $(top_builddir)/src/util/libxmlconfig.la \
+        $(top_builddir)/src/mapi/shared-glapi/libglapi.la \
         $(MEGADRIVERS_DEPS) \
         $(DRI_LIB_DEPS) \
         $()
 
+EXTRA_DIST = meson.build
+
 if NEED_MEGADRIVER
 dri_LTLIBRARIES = mesa_dri_drivers.la