meson: Build with Python 3
[mesa.git] / src / mesa / main / meson.build
index 57487fe4da55cdaf8d4be1dbcdc8126f21283e0e..a5f0e02c6cd93ca707c47856e909db47ef609b60 100644 (file)
@@ -22,7 +22,7 @@ main_dispatch_h = custom_target(
   'dispatch.h',
   input : [files('../../mapi/glapi/gen/gl_table.py'), gl_and_es_api_files],
   output : 'dispatch.h',
-  command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@', '-m', 'remap_table'],
+  command : [prog_python, '@INPUT0@', '-f', '@INPUT1@', '-m', 'remap_table'],
   depend_files : glapi_gen_depends,
   capture : true,
 )
@@ -31,7 +31,7 @@ main_marshal_generated_h = custom_target(
   'marshal_generated.h',
   input : [files('../../mapi/glapi/gen/gl_marshal_h.py'), gl_and_es_api_files],
   output : 'marshal_generated.h',
-  command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '-f', '@INPUT1@'],
   depend_files : files('../../mapi/glapi/gen/marshal_XML.py') + glapi_gen_depends,
   capture : true,
 )
@@ -40,7 +40,7 @@ main_remap_helper_h = custom_target(
   'remap_helper.h',
   input : [files('../../mapi/glapi/gen/remap_helper.py'), gl_and_es_api_files],
   output : 'remap_helper.h',
-  command : [prog_python2, '@INPUT0@', '-f', '@INPUT1@'],
+  command : [prog_python, '@INPUT0@', '-f', '@INPUT1@'],
   depend_files : glapi_gen_depends,
   capture : true,
 )