meson: rename `glvnd_missing_pc_files` to `not glvnd_has_headers_and_pc_files`
[mesa.git] / src / meson.build
index 10b2772f907d5bbf041353ff965fb901823c6169..15fa52be57c4f84c081e694be8b834de5a8d43ef 100644 (file)
@@ -112,12 +112,12 @@ endif
 
 # This must be after at least mesa, glx, and gallium, since libgl will be
 # defined in one of those subdirs depending on the glx provider.
-if with_glx != 'disabled' and (not with_glvnd or glvnd_missing_pc_files)
+if with_glx != 'disabled' and (not with_glvnd or not glvnd_has_headers_and_pc_files)
   # If using glvnd the pkg-config header should not point to GL_mesa, it should
   # point to GL. glvnd is only available on unix like platforms so adding -l
   # should be safe here
   # TODO: in the glvnd case glvnd itself should really be providing this.
-  if glvnd_missing_pc_files
+  if not glvnd_has_headers_and_pc_files
     _gl = '-L${libdir} -lGL'
   else
     _gl = libgl