meson: fix logic for generating .pc files with old glvnd
[mesa.git] / src / meson.build
index ddbcd7f3ae42819cae40caaa1146589f4ff30d57..d01f84c0d460a22668a8257fb063b001e1ba9d34 100644 (file)
@@ -111,12 +111,12 @@ endif
 
 # This must be after at least mesa, glx, and gallium, since libgl will be
 # defined in one of those subdirs depending on the glx provider.
-if with_glx != 'disabled'
+if with_glx != 'disabled' and (not with_glvnd or glvnd_missing_pc_files)
   # If using glvnd the pkg-config header should not point to GL_mesa, it should
   # point to GL. glvnd is only available on unix like platforms so adding -l
   # should be safe here
   # TODO: in the glvnd case glvnd itself should really be providing this.
-  if with_glvnd and glvnd_missing_pc_files
+  if glvnd_missing_pc_files
     _gl = '-L${libdir} -lGL'
   else
     _gl = libgl