lima,panfrost: Move lima_tiling.c/h to /src/panfrost
[mesa.git] / src / meson.build
index 0d0ecf2c530749592bef2997368239c4c0168568..0dcd7eef65ddfd8038b48607c6d6619dd5fcbb24 100644 (file)
@@ -18,8 +18,8 @@
 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
 # SOFTWARE.
 
-inc_common = include_directories(
-  '../include', '.', 'mapi', 'mesa', 'gallium/include', 'gallium/auxiliary')
+inc_common = [inc_include, include_directories(
+  '.', 'mapi', 'mesa', 'gallium/include', 'gallium/auxiliary')]
 inc_mesa = include_directories('mesa')
 inc_mapi = include_directories('mapi')
 inc_src = include_directories('.')
@@ -51,6 +51,7 @@ subdir('util')
 subdir('mapi')
 # TODO: opengl
 subdir('compiler')
+subdir('imgui')
 if with_platform_wayland
   subdir('egl/wayland/wayland-drm')
 endif
@@ -63,7 +64,16 @@ endif
 if with_gallium_vc4 or with_gallium_v3d
   subdir('broadcom')
 endif
-if with_dri_i965 or with_intel_vk
+if with_gallium_etnaviv
+  subdir('etnaviv')
+endif
+if with_gallium_freedreno or with_freedreno_vk
+  subdir('freedreno')
+endif
+if with_gallium_panfrost or with_gallium_lima
+  subdir('panfrost')
+endif
+if with_dri_i965 or with_intel_vk or with_gallium_iris
   subdir('intel')
 endif
 subdir('mesa')
@@ -71,7 +81,7 @@ subdir('loader')
 if with_platform_haiku
   subdir('hgl')
 endif
-if with_glx != 'disabled'
+if with_glx == 'dri'
   subdir('glx')
 endif
 if with_gbm