v3d: do not report alpha-test as supported
[mesa.git] / src / meson.build
index af881cff70bf752a6474b7f4ecb615f82a7162cd..15fa52be57c4f84c081e694be8b834de5a8d43ef 100644 (file)
 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
 # SOFTWARE.
 
-inc_common = include_directories(
-  '../include', '.', 'mapi', 'mesa', 'gallium/include', 'gallium/auxiliary')
+inc_common = [inc_include, include_directories(
+  '.', 'mapi', 'mesa', 'gallium/include', 'gallium/auxiliary')]
 inc_mesa = include_directories('mesa')
 inc_mapi = include_directories('mapi')
 inc_src = include_directories('.')
 inc_gallium = include_directories('gallium/include')
 inc_gallium_aux = include_directories('gallium/auxiliary')
 inc_amd_common = include_directories('amd/common')
+inc_amd_common_llvm = include_directories('amd/llvm')
 
 libglsl_util = static_library(
   'glsl_util',
@@ -47,19 +48,41 @@ sha1_h = custom_target(
 )
 
 subdir('gtest')
+if cc.get_id() == 'msvc'
+  subdir('getopt')
+else
+  idep_getopt = null_dep
+endif
 subdir('util')
 subdir('mapi')
 # TODO: opengl
 subdir('compiler')
-subdir('egl/wayland/wayland-drm')
-subdir('vulkan')
+if with_tools.contains('drm-shim')
+  subdir('drm-shim')
+endif
+subdir('imgui')
+if with_platform_wayland
+  subdir('egl/wayland/wayland-drm')
+endif
+if with_any_vk
+  subdir('vulkan')
+endif
 if with_gallium_radeonsi or with_amd_vk
   subdir('amd')
 endif
 if with_gallium_vc4 or with_gallium_v3d
   subdir('broadcom')
 endif
-if with_dri_i965 or with_intel_vk
+if with_gallium_etnaviv
+  subdir('etnaviv')
+endif
+if with_gallium_freedreno or with_freedreno_vk
+  subdir('freedreno')
+endif
+if with_gallium_panfrost or with_gallium_lima
+  subdir('panfrost')
+endif
+if with_dri_i965 or with_intel_vk or with_gallium_iris
   subdir('intel')
 endif
 subdir('mesa')
@@ -67,7 +90,7 @@ subdir('loader')
 if with_platform_haiku
   subdir('hgl')
 endif
-if with_glx != 'disabled'
+if with_glx == 'dri'
   subdir('glx')
 endif
 if with_gbm
@@ -82,19 +105,19 @@ if with_gallium
   subdir('gallium')
   # This has to be here since it requires libgallium, and subdir cannot
   # contain ..
-  if with_tests
+  if with_tests and with_shared_glapi
     subdir('mesa/state_tracker/tests')
   endif
 endif
 
 # This must be after at least mesa, glx, and gallium, since libgl will be
 # defined in one of those subdirs depending on the glx provider.
-if with_glx != 'disabled'
+if with_glx != 'disabled' and (not with_glvnd or not glvnd_has_headers_and_pc_files)
   # If using glvnd the pkg-config header should not point to GL_mesa, it should
   # point to GL. glvnd is only available on unix like platforms so adding -l
   # should be safe here
   # TODO: in the glvnd case glvnd itself should really be providing this.
-  if with_glvnd
+  if not glvnd_has_headers_and_pc_files
     _gl = '-L${libdir} -lGL'
   else
     _gl = libgl