meson: fix building without GL
[mesa.git] / src / meson.build
index b2c045fce10b38c8f79aebd48a6eef98b403b2b3..19005271d733b968bde273f905827df30c074c96 100644 (file)
@@ -82,18 +82,19 @@ if with_gallium
   subdir('gallium')
 endif
 
-# If using glvnd the pkg-config header should not point to GL_mesa, it should
-# point to GL. glvnd is only available on unix like platforms so adding -l
-# should be safe here
-# TODO: in the glvnd case glvnd itself should really be providing this.
-if with_glvnd
-  _gl = '-L${libdir} -lGL'
-else
-  _gl = libgl
-endif
 # This must be after at least mesa, glx, and gallium, since libgl will be
 # defined in one of those subdirs depending on the glx provider.
 if with_glx != 'disabled'
+  # If using glvnd the pkg-config header should not point to GL_mesa, it should
+  # point to GL. glvnd is only available on unix like platforms so adding -l
+  # should be safe here
+  # TODO: in the glvnd case glvnd itself should really be providing this.
+  if with_glvnd
+    _gl = '-L${libdir} -lGL'
+  else
+    _gl = libgl
+  endif
+
   pkg.generate(
     name : 'gl',
     description : 'Mesa OpenGL Library',