aco: fix spills_entry heuristic for branch blocks in init_live_in_vars()
[mesa.git] / src / meson.build
index accb7a9806d13ac14ebb8eace54e7ca0e9dfbdb4..1d8e7633369abbde7d1ff2e522fb87bf97cf18e7 100644 (file)
@@ -18,8 +18,6 @@
 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
 # SOFTWARE.
 
-inc_common = [inc_include, include_directories(
-  '.', 'mapi', 'mesa', 'gallium/include', 'gallium/auxiliary')]
 inc_mesa = include_directories('mesa')
 inc_mapi = include_directories('mapi')
 inc_src = include_directories('.')
@@ -32,11 +30,12 @@ libglsl_util = static_library(
   'glsl_util',
   files(
     'mesa/main/extensions_table.c',
-    'mesa/program/prog_parameter.c', 'mesa/program/symbol_table.c',
+    'mesa/program/prog_parameter.c',
+    'mesa/program/symbol_table.c',
     'mesa/program/dummy_errors.c',
   ),
-  include_directories : [inc_common],
-  c_args : [c_vis_args],
+  include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
+  gnu_symbol_visibility : 'hidden',
   build_by_default : false,
 )
 
@@ -44,7 +43,8 @@ sha1_h = custom_target(
   'git_sha1.h',
   output : 'git_sha1.h',
   command : [prog_python, git_sha1_gen_py, '--output', '@OUTPUT@'],
-  build_always : true, # commit sha1 can change without having touched these files
+  build_by_default : true,
+  build_always_stale : true, # commit sha1 can change without having touched these files
 )
 
 subdir('gtest')
@@ -53,6 +53,7 @@ if cc.get_id() == 'msvc'
 else
   idep_getopt = null_dep
 endif
+subdir('android_stub')
 subdir('util')
 subdir('mapi')
 # TODO: opengl
@@ -84,6 +85,9 @@ endif
 if with_gallium_panfrost or with_gallium_lima
   subdir('panfrost')
 endif
+if with_gallium_virgl
+  subdir('virtio')
+endif
 if with_dri_i965 or with_intel_vk or with_gallium_iris
   subdir('intel')
 endif