v3d: moving v3d simulator to src/broadcom
[mesa.git] / src / meson.build
index cf0c34c9560e76525fb944476caa6916ab879b08..26a815d6a15bda7c0baf3dd4da7ec4b7d82e247d 100644 (file)
@@ -30,11 +30,12 @@ libglsl_util = static_library(
   'glsl_util',
   files(
     'mesa/main/extensions_table.c',
-    'mesa/program/prog_parameter.c', 'mesa/program/symbol_table.c',
+    'mesa/program/prog_parameter.c',
+    'mesa/program/symbol_table.c',
     'mesa/program/dummy_errors.c',
   ),
   include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
-  c_args : [c_vis_args],
+  gnu_symbol_visibility : 'hidden',
   build_by_default : false,
 )
 
@@ -42,7 +43,8 @@ sha1_h = custom_target(
   'git_sha1.h',
   output : 'git_sha1.h',
   command : [prog_python, git_sha1_gen_py, '--output', '@OUTPUT@'],
-  build_always : true, # commit sha1 can change without having touched these files
+  build_by_default : true,
+  build_always_stale : true, # commit sha1 can change without having touched these files
 )
 
 subdir('gtest')