etnaviv: drm: Use mesa's atomic definitions
[mesa.git] / src / meson.build
index ae094fccf6cd1c288752ec3a21312b59b6465fa8..6d04b5fc3b2ae7a6f940fed27c82607cdefe4aae 100644 (file)
@@ -18,8 +18,8 @@
 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
 # SOFTWARE.
 
-inc_common = include_directories(
-  '../include', '.', 'mapi', 'mesa', 'gallium/include', 'gallium/auxiliary')
+inc_common = [inc_include, include_directories(
+  '.', 'mapi', 'mesa', 'gallium/include', 'gallium/auxiliary')]
 inc_mesa = include_directories('mesa')
 inc_mapi = include_directories('mapi')
 inc_src = include_directories('.')
@@ -51,6 +51,7 @@ subdir('util')
 subdir('mapi')
 # TODO: opengl
 subdir('compiler')
+subdir('imgui')
 if with_platform_wayland
   subdir('egl/wayland/wayland-drm')
 endif
@@ -63,10 +64,10 @@ endif
 if with_gallium_vc4 or with_gallium_v3d
   subdir('broadcom')
 endif
-if with_gallium_freedreno
+if with_gallium_freedreno or with_freedreno_vk
   subdir('freedreno')
 endif
-if with_dri_i965 or with_intel_vk
+if with_dri_i965 or with_intel_vk or with_gallium_iris
   subdir('intel')
 endif
 subdir('mesa')