vulkan: add vk_x11_strict_image_count option
[mesa.git] / src / meson.build
index 7f537b7094f1eba5ca8cbc242042a0672fd0ccb6..71ff82af38f8c9dabd273317ada2c8ad0ad48b1a 100644 (file)
@@ -47,10 +47,18 @@ sha1_h = custom_target(
 )
 
 subdir('gtest')
+if cc.get_id() == 'msvc'
+  subdir('getopt')
+else
+  idep_getopt = null_dep
+endif
 subdir('util')
 subdir('mapi')
 # TODO: opengl
 subdir('compiler')
+if with_tools.contains('drm-shim')
+  subdir('drm-shim')
+endif
 subdir('imgui')
 if with_platform_wayland
   subdir('egl/wayland/wayland-drm')
@@ -64,9 +72,15 @@ endif
 if with_gallium_vc4 or with_gallium_v3d
   subdir('broadcom')
 endif
-if with_gallium_freedreno
+if with_gallium_etnaviv
+  subdir('etnaviv')
+endif
+if with_gallium_freedreno or with_freedreno_vk
   subdir('freedreno')
 endif
+if with_gallium_panfrost or with_gallium_lima
+  subdir('panfrost')
+endif
 if with_dri_i965 or with_intel_vk or with_gallium_iris
   subdir('intel')
 endif