TODO: glx: meson: build dri based glx tests, only with -Dglx=dri
[mesa.git] / src / meson.build
index 2c0bff734320d40efe861f300a4f5903d0edb1da..ae094fccf6cd1c288752ec3a21312b59b6465fa8 100644 (file)
@@ -51,7 +51,9 @@ subdir('util')
 subdir('mapi')
 # TODO: opengl
 subdir('compiler')
-subdir('egl/wayland/wayland-drm')
+if with_platform_wayland
+  subdir('egl/wayland/wayland-drm')
+endif
 if with_any_vk
   subdir('vulkan')
 endif
@@ -61,6 +63,9 @@ endif
 if with_gallium_vc4 or with_gallium_v3d
   subdir('broadcom')
 endif
+if with_gallium_freedreno
+  subdir('freedreno')
+endif
 if with_dri_i965 or with_intel_vk
   subdir('intel')
 endif
@@ -69,7 +74,7 @@ subdir('loader')
 if with_platform_haiku
   subdir('hgl')
 endif
-if with_glx != 'disabled'
+if with_glx == 'dri'
   subdir('glx')
 endif
 if with_gbm