meson: Don't build intel shared components by default
[mesa.git] / src / meson.build
index 544d831ea638d12d5c7e91404918376074e031a3..c3b1ff00d001ac081bad1a18def830e1873d66a3 100644 (file)
@@ -23,6 +23,8 @@ inc_common = include_directories(
 inc_mesa = include_directories('mesa')
 inc_mapi = include_directories('mapi')
 inc_src = include_directories('.')
+inc_gallium = include_directories('gallium/include')
+inc_gallium_aux = include_directories('gallium/auxiliary')
 
 libglsl_util = static_library(
   'glsl_util',
@@ -34,9 +36,11 @@ libglsl_util = static_library(
   build_by_default : false,
 )
 
-sha1_h = vcs_tag(
-  input : 'git_sha1.h.in',
+sha1_h = custom_target(
+  'git_sha1.h',
   output : 'git_sha1.h',
+  command : [prog_python2, git_sha1_gen_py, '--output', '@OUTPUT@'],
+  build_always : true, # commit sha1 can change without having touched these files
 )
 
 subdir('gtest')
@@ -44,18 +48,37 @@ subdir('util')
 subdir('mapi/glapi/gen')
 subdir('mapi')
 # TODO: opengl
-# TODO: osmesa
 subdir('compiler')
 subdir('egl/wayland/wayland-drm')
 subdir('vulkan')
 subdir('amd')
-subdir('intel')
-# TODO: vc4
+if with_gallium_vc4
+  subdir('broadcom')
+endif
+if with_dri_i965 or with_intel_vk
+  subdir('intel')
+endif
 subdir('mesa')
 subdir('loader')
 subdir('glx')
 if with_gbm
   subdir('gbm')
 endif
-# TODO: egl
-# TODO: gallium
+if with_egl
+  subdir('egl')
+endif
+subdir('gallium')
+
+# This must be after at least mesa, glx, and gallium, since libgl will be
+# defined in one of those subdirs depending on the glx provider.
+if with_glx != 'disabled'
+  pkg.generate(
+    name : 'gl',
+    description : 'Mesa OpenGL Library',
+    version : meson.project_version(),
+    libraries : libgl,
+    libraries_private : gl_priv_libs,
+    requires_private : gl_priv_reqs,
+    variables : ['glx_tls=yes'],
+  )
+endif