meson: Don't link gbm with threads
[mesa.git] / src / meson.build
index 544d831ea638d12d5c7e91404918376074e031a3..cc8f5953c51489860ce4867d64290ef59e76d621 100644 (file)
@@ -23,6 +23,8 @@ inc_common = include_directories(
 inc_mesa = include_directories('mesa')
 inc_mapi = include_directories('mapi')
 inc_src = include_directories('.')
+inc_gallium = include_directories('gallium/include')
+inc_gallium_aux = include_directories('gallium/auxiliary')
 
 libglsl_util = static_library(
   'glsl_util',
@@ -34,9 +36,11 @@ libglsl_util = static_library(
   build_by_default : false,
 )
 
-sha1_h = vcs_tag(
-  input : 'git_sha1.h.in',
+sha1_h = custom_target(
+  'git_sha1.h',
   output : 'git_sha1.h',
+  command : [prog_python2, git_sha1_gen_py, '--output', '@OUTPUT@'],
+  build_always : true, # commit sha1 can change without having touched these files
 )
 
 subdir('gtest')
@@ -44,18 +48,24 @@ subdir('util')
 subdir('mapi/glapi/gen')
 subdir('mapi')
 # TODO: opengl
-# TODO: osmesa
 subdir('compiler')
 subdir('egl/wayland/wayland-drm')
 subdir('vulkan')
 subdir('amd')
+if with_gallium_vc4
+  subdir('broadcom')
+endif
 subdir('intel')
-# TODO: vc4
 subdir('mesa')
 subdir('loader')
 subdir('glx')
+if with_platform_wayland
+  subdir('egl/wayland/wayland-egl')
+endif
 if with_gbm
   subdir('gbm')
 endif
-# TODO: egl
-# TODO: gallium
+if with_egl
+  subdir('egl')
+endif
+subdir('gallium')