meson: re-add incorrect pkg-config files with GLVND for backward compatibility
[mesa.git] / src / meson.build
index 71ff82af38f8c9dabd273317ada2c8ad0ad48b1a..ddbcd7f3ae42819cae40caaa1146589f4ff30d57 100644 (file)
@@ -116,7 +116,7 @@ if with_glx != 'disabled'
   # point to GL. glvnd is only available on unix like platforms so adding -l
   # should be safe here
   # TODO: in the glvnd case glvnd itself should really be providing this.
-  if with_glvnd
+  if with_glvnd and glvnd_missing_pc_files
     _gl = '-L${libdir} -lGL'
   else
     _gl = libgl