meson: re-add incorrect pkg-config files with GLVND for backward compatibility
[mesa.git] / src / meson.build
index d86c0ec21a6184ab4f71e06208982efe60e0d0d9..ddbcd7f3ae42819cae40caaa1146589f4ff30d57 100644 (file)
@@ -47,6 +47,11 @@ sha1_h = custom_target(
 )
 
 subdir('gtest')
+if cc.get_id() == 'msvc'
+  subdir('getopt')
+else
+  idep_getopt = null_dep
+endif
 subdir('util')
 subdir('mapi')
 # TODO: opengl
@@ -111,7 +116,7 @@ if with_glx != 'disabled'
   # point to GL. glvnd is only available on unix like platforms so adding -l
   # should be safe here
   # TODO: in the glvnd case glvnd itself should really be providing this.
-  if with_glvnd
+  if with_glvnd and glvnd_missing_pc_files
     _gl = '-L${libdir} -lGL'
   else
     _gl = libgl