meson: re-add incorrect pkg-config files with GLVND for backward compatibility
[mesa.git] / src / meson.build
index d9fe8daa146d637b23e3dab694abe7911a66b065..ddbcd7f3ae42819cae40caaa1146589f4ff30d57 100644 (file)
@@ -18,8 +18,8 @@
 # OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
 # SOFTWARE.
 
-inc_common = include_directories(
-  '../include', '.', 'mapi', 'mesa', 'gallium/include', 'gallium/auxiliary')
+inc_common = [inc_include, include_directories(
+  '.', 'mapi', 'mesa', 'gallium/include', 'gallium/auxiliary')]
 inc_mesa = include_directories('mesa')
 inc_mapi = include_directories('mapi')
 inc_src = include_directories('.')
@@ -47,10 +47,18 @@ sha1_h = custom_target(
 )
 
 subdir('gtest')
+if cc.get_id() == 'msvc'
+  subdir('getopt')
+else
+  idep_getopt = null_dep
+endif
 subdir('util')
 subdir('mapi')
 # TODO: opengl
 subdir('compiler')
+if with_tools.contains('drm-shim')
+  subdir('drm-shim')
+endif
 subdir('imgui')
 if with_platform_wayland
   subdir('egl/wayland/wayland-drm')
@@ -64,10 +72,16 @@ endif
 if with_gallium_vc4 or with_gallium_v3d
   subdir('broadcom')
 endif
-if with_gallium_freedreno
+if with_gallium_etnaviv
+  subdir('etnaviv')
+endif
+if with_gallium_freedreno or with_freedreno_vk
   subdir('freedreno')
 endif
-if with_dri_i965 or with_intel_vk
+if with_gallium_panfrost or with_gallium_lima
+  subdir('panfrost')
+endif
+if with_dri_i965 or with_intel_vk or with_gallium_iris
   subdir('intel')
 endif
 subdir('mesa')
@@ -102,7 +116,7 @@ if with_glx != 'disabled'
   # point to GL. glvnd is only available on unix like platforms so adding -l
   # should be safe here
   # TODO: in the glvnd case glvnd itself should really be providing this.
-  if with_glvnd
+  if with_glvnd and glvnd_missing_pc_files
     _gl = '-L${libdir} -lGL'
   else
     _gl = libgl