Added few more stubs so that control reaches to DestroyDevice().
[mesa.git] / src / meson.build
index 26a815d6a15bda7c0baf3dd4da7ec4b7d82e247d..dfe41d08972ec6e35120aa54c4fcae10b3942c3a 100644 (file)
@@ -53,6 +53,7 @@ if cc.get_id() == 'msvc'
 else
   idep_getopt = null_dep
 endif
+subdir('android_stub')
 subdir('util')
 subdir('mapi')
 # TODO: opengl
@@ -84,9 +85,15 @@ endif
 if with_gallium_panfrost or with_gallium_lima
   subdir('panfrost')
 endif
+if with_gallium_virgl
+  subdir('virtio')
+endif
 if with_dri_i965 or with_intel_vk or with_gallium_iris
   subdir('intel')
 endif
+if with_libresoc_vk
+  subdir('libre-soc')
+endif
 subdir('mesa')
 subdir('loader')
 if with_platform_haiku
@@ -122,6 +129,6 @@ if with_glx != 'disabled' and not with_glvnd
     libraries : libgl,
     libraries_private : gl_priv_libs,
     requires_private : gl_priv_reqs,
-    variables : ['glx_tls=yes'],
+    variables : ['glx_tls=@0@'.format(use_elf_tls ? 'yes' : 'no')],
   )
 endif