Added few more stubs so that control reaches to DestroyDevice().
[mesa.git] / src / meson.build
index cf0c34c9560e76525fb944476caa6916ab879b08..dfe41d08972ec6e35120aa54c4fcae10b3942c3a 100644 (file)
@@ -30,11 +30,12 @@ libglsl_util = static_library(
   'glsl_util',
   files(
     'mesa/main/extensions_table.c',
   'glsl_util',
   files(
     'mesa/main/extensions_table.c',
-    'mesa/program/prog_parameter.c', 'mesa/program/symbol_table.c',
+    'mesa/program/prog_parameter.c',
+    'mesa/program/symbol_table.c',
     'mesa/program/dummy_errors.c',
   ),
   include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
     'mesa/program/dummy_errors.c',
   ),
   include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
-  c_args : [c_vis_args],
+  gnu_symbol_visibility : 'hidden',
   build_by_default : false,
 )
 
   build_by_default : false,
 )
 
@@ -42,7 +43,8 @@ sha1_h = custom_target(
   'git_sha1.h',
   output : 'git_sha1.h',
   command : [prog_python, git_sha1_gen_py, '--output', '@OUTPUT@'],
   'git_sha1.h',
   output : 'git_sha1.h',
   command : [prog_python, git_sha1_gen_py, '--output', '@OUTPUT@'],
-  build_always : true, # commit sha1 can change without having touched these files
+  build_by_default : true,
+  build_always_stale : true, # commit sha1 can change without having touched these files
 )
 
 subdir('gtest')
 )
 
 subdir('gtest')
@@ -51,6 +53,7 @@ if cc.get_id() == 'msvc'
 else
   idep_getopt = null_dep
 endif
 else
   idep_getopt = null_dep
 endif
+subdir('android_stub')
 subdir('util')
 subdir('mapi')
 # TODO: opengl
 subdir('util')
 subdir('mapi')
 # TODO: opengl
@@ -82,9 +85,15 @@ endif
 if with_gallium_panfrost or with_gallium_lima
   subdir('panfrost')
 endif
 if with_gallium_panfrost or with_gallium_lima
   subdir('panfrost')
 endif
+if with_gallium_virgl
+  subdir('virtio')
+endif
 if with_dri_i965 or with_intel_vk or with_gallium_iris
   subdir('intel')
 endif
 if with_dri_i965 or with_intel_vk or with_gallium_iris
   subdir('intel')
 endif
+if with_libresoc_vk
+  subdir('libre-soc')
+endif
 subdir('mesa')
 subdir('loader')
 if with_platform_haiku
 subdir('mesa')
 subdir('loader')
 if with_platform_haiku
@@ -120,6 +129,6 @@ if with_glx != 'disabled' and not with_glvnd
     libraries : libgl,
     libraries_private : gl_priv_libs,
     requires_private : gl_priv_reqs,
     libraries : libgl,
     libraries_private : gl_priv_libs,
     requires_private : gl_priv_reqs,
-    variables : ['glx_tls=yes'],
+    variables : ['glx_tls=@0@'.format(use_elf_tls ? 'yes' : 'no')],
   )
 endif
   )
 endif