util: delete fnv1a hash function
[mesa.git] / src / util / meson.build
index 8326691f408e5e8f9d0a9e2f0d4115036c705779..1fda53bafd536f26c73d1dbf8a9396ad7a09e498 100644 (file)
@@ -20,6 +20,7 @@
 
 inc_util = include_directories('.')
 
+subdir('format')
 subdir('xmlpool')
 
 files_mesa_util = files(
@@ -29,8 +30,11 @@ files_mesa_util = files(
   'bitscan.c',
   'bitscan.h',
   'bitset.h',
+  'blob.c',
+  'blob.h',
   'build_id.c',
   'build_id.h',
+  'compiler.h',
   'crc32.c',
   'crc32.h',
   'dag.c',
@@ -38,6 +42,8 @@ files_mesa_util = files(
   'debug.h',
   'disk_cache.c',
   'disk_cache.h',
+  'double.c',
+  'double.h',
   'fast_idiv_by_const.c',
   'fast_idiv_by_const.h',
   'format_r11g11b10f.h',
@@ -57,6 +63,8 @@ files_mesa_util = files(
   'os_file.c',
   'os_misc.c',
   'os_misc.h',
+  'os_socket.c',
+  'os_socket.h',
   'u_process.c',
   'u_process.h',
   'sha1/sha1.c',
@@ -80,6 +88,8 @@ files_mesa_util = files(
   'slab.h',
   'softfloat.c',
   'softfloat.h',
+  'sparse_array.c',
+  'sparse_array.h',
   'string_buffer.c',
   'string_buffer.h',
   'strndup.h',
@@ -99,12 +109,17 @@ files_mesa_util = files(
   'u_vector.h',
   'u_math.c',
   'u_math.h',
+  'u_memset.h',
+  'u_mm.c',
+  'u_mm.h',
   'u_debug.c',
   'u_debug.h',
+  'u_debug_memory.c',
   'u_cpu_detect.c',
   'u_cpu_detect.h',
   'vma.c',
   'vma.h',
+  'xxhash.h',
 )
 
 files_drirc = files('00-mesa-defaults.conf')
@@ -142,6 +157,8 @@ deps_for_libmesa_util = [
   dep_thread,
   dep_atomic,
   dep_m,
+  dep_valgrind,
+  dep_zstd,
 ]
 
 if with_platform_android
@@ -151,8 +168,9 @@ endif
 _libmesa_util = static_library(
   'mesa_util',
   [files_mesa_util, format_srgb],
-  include_directories : inc_common,
+  include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
   dependencies : deps_for_libmesa_util,
+  link_with: libmesa_format,
   c_args : [c_msvc_compat_args, c_vis_args],
   build_by_default : false
 )
@@ -166,7 +184,7 @@ idep_mesautil = declare_dependency(
 _libxmlconfig = static_library(
   'xmlconfig',
   files_xmlconfig,
-  include_directories : inc_common,
+  include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
   dependencies : [idep_mesautil, dep_expat, dep_m],
   c_args : [
     c_msvc_compat_args, c_vis_args,
@@ -181,10 +199,8 @@ _libxmlconfig = static_library(
 )
 
 idep_xmlconfig = declare_dependency(
-  sources : xmlpool_options_h,
-  include_directories : inc_util,
+  dependencies : [idep_xmlconfig_headers, dep_expat],
   link_with : _libxmlconfig,
-  dependencies : dep_expat,
 )
 
 if with_tests
@@ -193,7 +209,7 @@ if with_tests
     executable(
       'u_atomic_test',
       files('u_atomic_test.c'),
-      include_directories : inc_common,
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : idep_mesautil,
       c_args : [c_msvc_compat_args],
     ),
@@ -201,45 +217,107 @@ if with_tests
   )
 
   test(
-    'roundeven',
+    'blob',
     executable(
-      'roundeven_test',
-      files('roundeven_test.c'),
-      include_directories : inc_common,
+      'blob_test',
+      files('blob_test.c'),
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
+      dependencies : idep_mesautil,
       c_args : [c_msvc_compat_args],
-      dependencies : [dep_m],
     ),
     suite : ['util'],
   )
 
   test(
-    'mesa-sha1',
+    'rb_tree',
     executable(
-      'mesa-sha1_test',
-      files('mesa-sha1_test.c'),
-      include_directories : inc_common,
+      'rb_tree_test',
+      files('rb_tree_test.c'),
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : idep_mesautil,
       c_args : [c_msvc_compat_args],
     ),
     suite : ['util'],
   )
 
+  test(
+    'roundeven',
+    executable(
+      'roundeven_test',
+      files('roundeven_test.c'),
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
+      c_args : [c_msvc_compat_args],
+      dependencies : [dep_m],
+    ),
+    suite : ['util'],
+    should_fail : meson.get_cross_property('xfail', '').contains('roundeven'),
+  )
+
+  # FIXME: this test crashes on windows
+  if host_machine.system() != 'windows'
+    test(
+      'mesa-sha1',
+      executable(
+        'mesa-sha1_test',
+        files('mesa-sha1_test.c'),
+        include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
+        link_with : _libmesa_util,
+        c_args : [c_msvc_compat_args],
+      ),
+      suite : ['util'],
+    )
+  endif
+
   test(
     'bitset',
     executable(
        'bitset_test',
        files('bitset_test.cpp'),
-       include_directories : inc_common,
+       include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
        dependencies : [idep_mesautil, idep_gtest],
      ),
      suite : ['util'],
   )
 
+  process_test_exe = executable(
+    'process_test',
+    files('process_test.c'),
+    include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
+    dependencies : idep_mesautil,
+    c_args : [c_msvc_compat_args],
+  )
+  if (host_machine.system() == 'windows' and build_machine.system() != 'windows')
+    # This conversion is only required on mingw crosscompilers, otherwise we hit at least one of these issues
+    # https://gitlab.freedesktop.org/mesa/mesa/-/issues/2690
+    # https://gitlab.freedesktop.org/mesa/mesa/-/issues/2788
+    prog_winepath = find_program('winepath')
+    process_test_exe_full_path = run_command(
+      prog_winepath, '-w', process_test_exe.full_path()
+    ).stdout().strip()
+  else
+    process_test_exe_full_path = process_test_exe.full_path()
+  endif
+
+  test(
+    'process',
+    process_test_exe,
+    suite : ['util'],
+    env: ['BUILD_FULL_PATH='+process_test_exe_full_path]
+  )
+
   subdir('tests/fast_idiv_by_const')
   subdir('tests/fast_urem_by_const')
   subdir('tests/hash_table')
-  subdir('tests/string_buffer')
-  subdir('tests/timespec')
+  if not (host_machine.system() == 'windows' and cc.get_id() == 'gcc')
+    # FIXME: These tests fail with mingw, but not with msvc.
+    subdir('tests/string_buffer')
+  endif
+  if cc.has_header('sys/time.h')  # MinGW has this, but Vanilla windows doesn't
+    subdir('tests/timespec')
+  endif
   subdir('tests/vma')
   subdir('tests/set')
+  subdir('tests/sparse_array')
+  subdir('tests/format')
+  subdir('tests/vector')
 endif