util/hash_table: Properly handle the NULL key in hash_table_u64
[mesa.git] / src / util / meson.build
index 489b6df17103d86df9e3ab3c61bcd3c5b7e74b5a..23f8c68c701deb8414216baedf7997b5ba5e529a 100644 (file)
@@ -195,7 +195,20 @@ if with_tests
     suite : ['util'],
   )
 
+  test(
+    'bitset',
+    executable(
+       'bitset_test',
+       files('bitset_test.cpp'),
+       include_directories : inc_common,
+       dependencies : [dep_thread, dep_dl, idep_gtest],
+       link_with : libmesa_util,
+     ),
+     suite : ['util'],
+  )
+
   subdir('tests/fast_idiv_by_const')
+  subdir('tests/fast_urem_by_const')
   subdir('tests/hash_table')
   subdir('tests/string_buffer')
   subdir('tests/vma')