util: Add a helper for faster remainders
[mesa.git] / src / util / meson.build
index 4f64681f191a9a3b0a55fae58e9d2b907f693a92..23f8c68c701deb8414216baedf7997b5ba5e529a 100644 (file)
@@ -31,6 +31,7 @@ files_mesa_util = files(
   'build_id.h',
   'crc32.c',
   'crc32.h',
+  'dag.c',
   'debug.c',
   'debug.h',
   'disk_cache.c',
@@ -51,6 +52,7 @@ files_mesa_util = files(
   'mesa-sha1.h',
   'os_time.c',
   'os_time.h',
+  'os_file.c',
   'os_misc.c',
   'os_misc.h',
   'u_process.c',
@@ -193,7 +195,20 @@ if with_tests
     suite : ['util'],
   )
 
+  test(
+    'bitset',
+    executable(
+       'bitset_test',
+       files('bitset_test.cpp'),
+       include_directories : inc_common,
+       dependencies : [dep_thread, dep_dl, idep_gtest],
+       link_with : libmesa_util,
+     ),
+     suite : ['util'],
+  )
+
   subdir('tests/fast_idiv_by_const')
+  subdir('tests/fast_urem_by_const')
   subdir('tests/hash_table')
   subdir('tests/string_buffer')
   subdir('tests/vma')