gitlab-ci: Add ppc64el and s390x cross-build jobs
[mesa.git] / src / util / meson.build
index 66d097783cc9784e62c88f37fd00eded38004713..3b2ac083a145960c8fc8979f97912f7522e85842 100644 (file)
@@ -45,6 +45,7 @@ files_mesa_util = files(
   'double.h',
   'fast_idiv_by_const.c',
   'fast_idiv_by_const.h',
+  'fnv1a.h',
   'format_r11g11b10f.h',
   'format_rgb9e5.h',
   'format_srgb.h',
@@ -247,6 +248,7 @@ if with_tests
       dependencies : [dep_m],
     ),
     suite : ['util'],
+    should_fail : meson.get_cross_property('xfail', '').contains('roundeven'),
   )
 
   # FIXME: this test crashes on windows