util: move u_cpu_detect to util
[mesa.git] / src / util / meson.build
index cdbad98e7cbe85b9313fddfae4173b8bd2f8915c..7caea27d6600b483c1f87bffe1f8aaa96fde9707 100644 (file)
@@ -51,6 +51,8 @@ files_mesa_util = files(
   'mesa-sha1.h',
   'os_time.c',
   'os_time.h',
+  'os_misc.c',
+  'os_misc.h',
   'u_process.c',
   'u_process.h',
   'sha1/sha1.c',
@@ -90,6 +92,10 @@ files_mesa_util = files(
   'u_vector.h',
   'u_math.c',
   'u_math.h',
+  'u_debug.c',
+  'u_debug.h',
+  'u_cpu_detect.c',
+  'u_cpu_detect.h',
   'vma.c',
   'vma.h',
 )
@@ -170,6 +176,7 @@ if with_tests
     )
   )
 
+  subdir('tests/fast_idiv_by_const')
   subdir('tests/hash_table')
   subdir('tests/string_buffer')
   subdir('tests/vma')