util/ra: Add [de]serialization support
[mesa.git] / src / util / meson.build
index 68ae31f421b20bc01f1d51ae285459d3cb9d923c..7ea125e5ac8442c4dfc2c0924e29805a6324d446 100644 (file)
@@ -287,10 +287,13 @@ if with_tests
     dependencies : idep_mesautil,
     c_args : [c_msvc_compat_args],
   )
-  if (host_machine.system() == 'windows' and cc.get_id() == 'gcc')
-    # This conversion is only required on mingw
+  if (host_machine.system() == 'windows' and build_machine.system() != 'windows')
+    # This conversion is only required on mingw crosscompilers, otherwise we hit at least one of these issues
+    # https://gitlab.freedesktop.org/mesa/mesa/-/issues/2690
+    # https://gitlab.freedesktop.org/mesa/mesa/-/issues/2788
+    prog_winepath = find_program('winepath')
     process_test_exe_full_path = run_command(
-      'winepath', '-w', process_test_exe.full_path()
+      prog_winepath, '-w', process_test_exe.full_path()
     ).stdout().strip()
   else
     process_test_exe_full_path = process_test_exe.full_path()
@@ -315,10 +318,7 @@ if with_tests
   endif
   subdir('tests/vma')
   subdir('tests/set')
-  # FIXME: this test on the Wine version in GitLab CI
-  if host_machine.system() != 'windows'
-    subdir('tests/sparse_array')
-  endif
+  subdir('tests/sparse_array')
   subdir('tests/format')
   subdir('tests/vector')
 endif