util/os_socket: Add socket related functions.
[mesa.git] / src / util / meson.build
index 489b6df17103d86df9e3ab3c61bcd3c5b7e74b5a..88c6ab2d2a8f2d770705a63e981bdc9121a34cf1 100644 (file)
 
 inc_util = include_directories('.')
 
+subdir('format')
 subdir('xmlpool')
 
 files_mesa_util = files(
+  'anon_file.h',
+  'anon_file.c',
   'bigmath.h',
   'bitscan.c',
   'bitscan.h',
   'bitset.h',
+  'blob.c',
+  'blob.h',
   'build_id.c',
   'build_id.h',
   'crc32.c',
@@ -36,6 +41,8 @@ files_mesa_util = files(
   'debug.h',
   'disk_cache.c',
   'disk_cache.h',
+  'double.c',
+  'double.h',
   'fast_idiv_by_const.c',
   'fast_idiv_by_const.h',
   'format_r11g11b10f.h',
@@ -55,6 +62,8 @@ files_mesa_util = files(
   'os_file.c',
   'os_misc.c',
   'os_misc.h',
+  'os_socket.c',
+  'os_socket.h',
   'u_process.c',
   'u_process.h',
   'sha1/sha1.c',
@@ -76,12 +85,17 @@ files_mesa_util = files(
   'simple_mtx.h',
   'slab.c',
   'slab.h',
+  'softfloat.c',
+  'softfloat.h',
+  'sparse_array.c',
+  'sparse_array.h',
   'string_buffer.c',
   'string_buffer.h',
   'strndup.h',
   'strtod.c',
   'strtod.h',
   'texcompress_rgtc_tmp.h',
+  'timespec.h',
   'u_atomic.c',
   'u_atomic.h',
   'u_dynarray.h',
@@ -94,6 +108,8 @@ files_mesa_util = files(
   'u_vector.h',
   'u_math.c',
   'u_math.h',
+  'u_mm.c',
+  'u_mm.h',
   'u_debug.c',
   'u_debug.h',
   'u_cpu_detect.c',
@@ -131,21 +147,41 @@ format_srgb = custom_target(
   capture : true,
 )
 
-libmesa_util = static_library(
+deps_for_libmesa_util = [
+  dep_zlib,
+  dep_clock,
+  dep_thread,
+  dep_atomic,
+  dep_m,
+  dep_valgrind,
+  dep_zstd,
+]
+
+if with_platform_android
+  deps_for_libmesa_util += dep_android
+endif
+
+_libmesa_util = static_library(
   'mesa_util',
   [files_mesa_util, format_srgb],
   include_directories : inc_common,
-  dependencies : [dep_zlib, dep_clock, dep_thread, dep_atomic, dep_m],
+  dependencies : deps_for_libmesa_util,
+  link_with: libmesa_format,
   c_args : [c_msvc_compat_args, c_vis_args],
   build_by_default : false
 )
 
-libxmlconfig = static_library(
+idep_mesautil = declare_dependency(
+  link_with : _libmesa_util,
+  include_directories : inc_util,
+  dependencies : [dep_zlib, dep_clock, dep_thread, dep_atomic, dep_m],
+)
+
+_libxmlconfig = static_library(
   'xmlconfig',
   files_xmlconfig,
   include_directories : inc_common,
-  link_with : libmesa_util,
-  dependencies : [dep_expat, dep_m],
+  dependencies : [idep_mesautil, dep_expat, dep_m],
   c_args : [
     c_msvc_compat_args, c_vis_args,
     '-DSYSCONFDIR="@0@"'.format(
@@ -158,6 +194,11 @@ libxmlconfig = static_library(
   build_by_default : false,
 )
 
+idep_xmlconfig = declare_dependency(
+  dependencies : [idep_xmlconfig_headers, dep_expat],
+  link_with : _libxmlconfig,
+)
+
 if with_tests
   test(
     'u_atomic',
@@ -165,39 +206,85 @@ if with_tests
       'u_atomic_test',
       files('u_atomic_test.c'),
       include_directories : inc_common,
-      link_with : libmesa_util,
+      dependencies : idep_mesautil,
       c_args : [c_msvc_compat_args],
     ),
     suite : ['util'],
   )
 
   test(
-    'roundeven',
+    'blob',
     executable(
-      'roundeven_test',
-      files('roundeven_test.c'),
+      'blob_test',
+      files('blob_test.c'),
       include_directories : inc_common,
+      dependencies : idep_mesautil,
+      c_args : [c_msvc_compat_args],
+    ),
+    suite : ['util'],
+  )
+
+  test(
+    'rb_tree',
+    executable(
+      'rb_tree_test',
+      files('rb_tree_test.c'),
+      include_directories : inc_common,
+      dependencies : idep_mesautil,
       c_args : [c_msvc_compat_args],
-      dependencies : [dep_m],
     ),
     suite : ['util'],
   )
 
   test(
-    'mesa-sha1',
+    'roundeven',
     executable(
-      'mesa-sha1_test',
-      files('mesa-sha1_test.c'),
+      'roundeven_test',
+      files('roundeven_test.c'),
       include_directories : inc_common,
-      link_with : libmesa_util,
       c_args : [c_msvc_compat_args],
+      dependencies : [dep_m],
     ),
     suite : ['util'],
   )
 
+  # FIXME: this test crashes on windows
+  if host_machine.system() != 'windows'
+    test(
+      'mesa-sha1',
+      executable(
+        'mesa-sha1_test',
+        files('mesa-sha1_test.c'),
+        include_directories : inc_common,
+        link_with : _libmesa_util,
+        c_args : [c_msvc_compat_args],
+      ),
+      suite : ['util'],
+    )
+  endif
+
+  test(
+    'bitset',
+    executable(
+       'bitset_test',
+       files('bitset_test.cpp'),
+       include_directories : inc_common,
+       dependencies : [idep_mesautil, idep_gtest],
+     ),
+     suite : ['util'],
+  )
+
   subdir('tests/fast_idiv_by_const')
+  subdir('tests/fast_urem_by_const')
   subdir('tests/hash_table')
-  subdir('tests/string_buffer')
+  if not (host_machine.system() == 'windows' and cc.get_id() == 'gcc')
+    # FIXME: These tests fail with mingw, but not with msvc.
+    subdir('tests/string_buffer')
+  endif
+  if cc.has_header('sys/time.h')  # MinGW has this, but Vanilla windows doesn't
+    subdir('tests/timespec')
+  endif
   subdir('tests/vma')
   subdir('tests/set')
+  subdir('tests/sparse_array')
 endif