util/os_socket: Add socket related functions.
[mesa.git] / src / util / meson.build
index 8260fbab2de9b65a057a10e4bb40ce8a9775dbcc..88c6ab2d2a8f2d770705a63e981bdc9121a34cf1 100644 (file)
@@ -20,6 +20,7 @@
 
 inc_util = include_directories('.')
 
+subdir('format')
 subdir('xmlpool')
 
 files_mesa_util = files(
@@ -61,6 +62,8 @@ files_mesa_util = files(
   'os_file.c',
   'os_misc.c',
   'os_misc.h',
+  'os_socket.c',
+  'os_socket.h',
   'u_process.c',
   'u_process.h',
   'sha1/sha1.c',
@@ -84,6 +87,8 @@ files_mesa_util = files(
   'slab.h',
   'softfloat.c',
   'softfloat.h',
+  'sparse_array.c',
+  'sparse_array.h',
   'string_buffer.c',
   'string_buffer.h',
   'strndup.h',
@@ -103,6 +108,8 @@ files_mesa_util = files(
   'u_vector.h',
   'u_math.c',
   'u_math.h',
+  'u_mm.c',
+  'u_mm.h',
   'u_debug.c',
   'u_debug.h',
   'u_cpu_detect.c',
@@ -147,6 +154,7 @@ deps_for_libmesa_util = [
   dep_atomic,
   dep_m,
   dep_valgrind,
+  dep_zstd,
 ]
 
 if with_platform_android
@@ -158,6 +166,7 @@ _libmesa_util = static_library(
   [files_mesa_util, format_srgb],
   include_directories : inc_common,
   dependencies : deps_for_libmesa_util,
+  link_with: libmesa_format,
   c_args : [c_msvc_compat_args, c_vis_args],
   build_by_default : false
 )
@@ -186,10 +195,8 @@ _libxmlconfig = static_library(
 )
 
 idep_xmlconfig = declare_dependency(
-  sources : xmlpool_options_h,
-  include_directories : inc_util,
+  dependencies : [idep_xmlconfig_headers, dep_expat],
   link_with : _libxmlconfig,
-  dependencies : dep_expat,
 )
 
 if with_tests
@@ -270,8 +277,14 @@ if with_tests
   subdir('tests/fast_idiv_by_const')
   subdir('tests/fast_urem_by_const')
   subdir('tests/hash_table')
-  subdir('tests/string_buffer')
-  subdir('tests/timespec')
+  if not (host_machine.system() == 'windows' and cc.get_id() == 'gcc')
+    # FIXME: These tests fail with mingw, but not with msvc.
+    subdir('tests/string_buffer')
+  endif
+  if cc.has_header('sys/time.h')  # MinGW has this, but Vanilla windows doesn't
+    subdir('tests/timespec')
+  endif
   subdir('tests/vma')
   subdir('tests/set')
+  subdir('tests/sparse_array')
 endif