util/os_misc: os_get_available_system_memory() for OpenBSD
[mesa.git] / src / util / meson.build
index 909b3e074683325be78c01689d83abd7bc9ed707..976034cc7297a3f8eb818b9c1ceccdd35db4da6c 100644 (file)
@@ -43,6 +43,7 @@ files_mesa_util = files(
   'disk_cache.h',
   'double.c',
   'double.h',
+  'enum_operators.h',
   'fast_idiv_by_const.c',
   'fast_idiv_by_const.h',
   'format_r11g11b10f.h',
@@ -289,6 +290,18 @@ if with_tests
      suite : ['util'],
   )
 
+  test(
+    'u_debug_stack',
+    executable(
+      'u_debug_stack_test',
+      files('u_debug_stack_test.cpp'),
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
+      dependencies : [idep_mesautil, idep_gtest],
+      c_args : [c_msvc_compat_args],
+    ),
+     suite : ['util'],
+  )
+
   process_test_exe = executable(
     'process_test',
     files('process_test.c'),