Added few more stubs so that control reaches to DestroyDevice().
[mesa.git] / src / util / meson.build
index d6647c0c5c38d3ccb6809ed5bea2d9a579b78d69..976034cc7297a3f8eb818b9c1ceccdd35db4da6c 100644 (file)
@@ -21,7 +21,6 @@
 inc_util = include_directories('.')
 
 subdir('format')
-subdir('xmlpool')
 
 files_mesa_util = files(
   'anon_file.h',
@@ -44,9 +43,9 @@ files_mesa_util = files(
   'disk_cache.h',
   'double.c',
   'double.h',
+  'enum_operators.h',
   'fast_idiv_by_const.c',
   'fast_idiv_by_const.h',
-  'fnv1a.h',
   'format_r11g11b10f.h',
   'format_rgb9e5.h',
   'format_srgb.h',
@@ -55,8 +54,6 @@ files_mesa_util = files(
   'half_float.h',
   'hash_table.c',
   'hash_table.h',
-  'imports.c',
-  'imports.h',
   'list.h',
   'macros.h',
   'mesa-sha1.c',
@@ -112,6 +109,7 @@ files_mesa_util = files(
   'u_vector.h',
   'u_math.c',
   'u_math.h',
+  'u_memset.h',
   'u_mm.c',
   'u_mm.h',
   'u_debug.c',
@@ -161,19 +159,29 @@ deps_for_libmesa_util = [
   dep_m,
   dep_valgrind,
   dep_zstd,
+  dep_dl,
+  dep_unwind,
 ]
 
 if with_platform_android
   deps_for_libmesa_util += dep_android
+  files_debug_stack = files('u_debug_stack_android.cpp')
+ else
+  files_debug_stack = files(
+    'u_debug_stack.c',
+    'u_debug_symbol.c',
+    'u_debug_symbol.h',
+  )
 endif
 
 _libmesa_util = static_library(
   'mesa_util',
-  [files_mesa_util, format_srgb],
-  include_directories : inc_common,
+  [files_mesa_util, files_debug_stack, format_srgb],
+  include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
   dependencies : deps_for_libmesa_util,
   link_with: libmesa_format,
-  c_args : [c_msvc_compat_args, c_vis_args],
+  c_args : [c_msvc_compat_args],
+  gnu_symbol_visibility : 'hidden',
   build_by_default : false
 )
 
@@ -186,10 +194,10 @@ idep_mesautil = declare_dependency(
 _libxmlconfig = static_library(
   'xmlconfig',
   files_xmlconfig,
-  include_directories : inc_common,
+  include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
   dependencies : [idep_mesautil, dep_expat, dep_m],
   c_args : [
-    c_msvc_compat_args, c_vis_args,
+    c_msvc_compat_args,
     '-DSYSCONFDIR="@0@"'.format(
       join_paths(get_option('prefix'), get_option('sysconfdir'))
     ),
@@ -197,11 +205,12 @@ _libxmlconfig = static_library(
       join_paths(get_option('prefix'), get_option('datadir'))
     ),
   ],
+  gnu_symbol_visibility : 'hidden',
   build_by_default : false,
 )
 
 idep_xmlconfig = declare_dependency(
-  dependencies : [idep_xmlconfig_headers, dep_expat],
+  dependencies : dep_expat,
   link_with : _libxmlconfig,
 )
 
@@ -211,7 +220,7 @@ if with_tests
     executable(
       'u_atomic_test',
       files('u_atomic_test.c'),
-      include_directories : inc_common,
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : idep_mesautil,
       c_args : [c_msvc_compat_args],
     ),
@@ -223,7 +232,7 @@ if with_tests
     executable(
       'blob_test',
       files('blob_test.c'),
-      include_directories : inc_common,
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : idep_mesautil,
       c_args : [c_msvc_compat_args],
     ),
@@ -235,7 +244,7 @@ if with_tests
     executable(
       'rb_tree_test',
       files('rb_tree_test.c'),
-      include_directories : inc_common,
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       dependencies : idep_mesautil,
       c_args : [c_msvc_compat_args],
     ),
@@ -247,7 +256,7 @@ if with_tests
     executable(
       'roundeven_test',
       files('roundeven_test.c'),
-      include_directories : inc_common,
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
       c_args : [c_msvc_compat_args],
       dependencies : [dep_m],
     ),
@@ -262,7 +271,7 @@ if with_tests
       executable(
         'mesa-sha1_test',
         files('mesa-sha1_test.c'),
-        include_directories : inc_common,
+        include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
         link_with : _libmesa_util,
         c_args : [c_msvc_compat_args],
       ),
@@ -275,23 +284,38 @@ if with_tests
     executable(
        'bitset_test',
        files('bitset_test.cpp'),
-       include_directories : inc_common,
+       include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
        dependencies : [idep_mesautil, idep_gtest],
      ),
      suite : ['util'],
   )
 
+  test(
+    'u_debug_stack',
+    executable(
+      'u_debug_stack_test',
+      files('u_debug_stack_test.cpp'),
+      include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
+      dependencies : [idep_mesautil, idep_gtest],
+      c_args : [c_msvc_compat_args],
+    ),
+     suite : ['util'],
+  )
+
   process_test_exe = executable(
     'process_test',
     files('process_test.c'),
-    include_directories : inc_common,
+    include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux],
     dependencies : idep_mesautil,
     c_args : [c_msvc_compat_args],
   )
-  if (host_machine.system() == 'windows' and cc.get_id() == 'gcc')
-    # This conversion is only required on mingw
+  if (host_machine.system() == 'windows' and build_machine.system() != 'windows')
+    # This conversion is only required on mingw crosscompilers, otherwise we hit at least one of these issues
+    # https://gitlab.freedesktop.org/mesa/mesa/-/issues/2690
+    # https://gitlab.freedesktop.org/mesa/mesa/-/issues/2788
+    prog_winepath = find_program('winepath')
     process_test_exe_full_path = run_command(
-      'winepath', '-w', process_test_exe.full_path()
+      prog_winepath, '-w', process_test_exe.full_path()
     ).stdout().strip()
   else
     process_test_exe_full_path = process_test_exe.full_path()
@@ -316,10 +340,7 @@ if with_tests
   endif
   subdir('tests/vma')
   subdir('tests/set')
-  # FIXME: this test on the Wine version in GitLab CI
-  if host_machine.system() != 'windows'
-    subdir('tests/sparse_array')
-  endif
+  subdir('tests/sparse_array')
   subdir('tests/format')
   subdir('tests/vector')
 endif