meson: replace libmesa_util with idep_mesautil
[mesa.git] / src / util / meson.build
index 7caea27d6600b483c1f87bffe1f8aaa96fde9707..d3c186366fb3a811f99cc432a5220e291627dc67 100644 (file)
@@ -31,6 +31,7 @@ files_mesa_util = files(
   'build_id.h',
   'crc32.c',
   'crc32.h',
+  'dag.c',
   'debug.c',
   'debug.h',
   'disk_cache.c',
@@ -51,6 +52,7 @@ files_mesa_util = files(
   'mesa-sha1.h',
   'os_time.c',
   'os_time.h',
+  'os_file.c',
   'os_misc.c',
   'os_misc.h',
   'u_process.c',
@@ -80,6 +82,7 @@ files_mesa_util = files(
   'strtod.c',
   'strtod.h',
   'texcompress_rgtc_tmp.h',
+  'timespec.h',
   'u_atomic.c',
   'u_atomic.h',
   'u_dynarray.h',
@@ -100,7 +103,21 @@ files_mesa_util = files(
   'vma.h',
 )
 
-install_data('00-mesa-defaults.conf', install_dir : join_paths(get_option('datadir'), 'drirc.d'))
+files_drirc = files('00-mesa-defaults.conf')
+
+install_data(files_drirc, install_dir : join_paths(get_option('datadir'), 'drirc.d'))
+
+if with_tests
+  prog_xmllint = find_program('xmllint', required : false, native : true)
+  if prog_xmllint.found()
+    test(
+      'drirc xml validation',
+      prog_xmllint,
+      args : ['--noout', '--valid', files_drirc],
+      suite : ['util'],
+    )
+  endif
+endif
 
 files_xmlconfig = files(
   'xmlconfig.c',
@@ -115,21 +132,26 @@ format_srgb = custom_target(
   capture : true,
 )
 
-libmesa_util = static_library(
+_libmesa_util = static_library(
   'mesa_util',
   [files_mesa_util, format_srgb],
   include_directories : inc_common,
-  dependencies : [dep_zlib, dep_clock, dep_thread, dep_atomic],
+  dependencies : [dep_zlib, dep_clock, dep_thread, dep_atomic, dep_m],
   c_args : [c_msvc_compat_args, c_vis_args],
   build_by_default : false
 )
 
+idep_mesautil = declare_dependency(
+  link_with : _libmesa_util,
+  include_directories : inc_util,
+  dependencies : [dep_zlib, dep_clock, dep_thread, dep_atomic, dep_m],
+)
+
 libxmlconfig = static_library(
   'xmlconfig',
   files_xmlconfig,
   include_directories : inc_common,
-  link_with : libmesa_util,
-  dependencies : [dep_expat, dep_m],
+  dependencies : [idep_mesautil, dep_expat, dep_m],
   c_args : [
     c_msvc_compat_args, c_vis_args,
     '-DSYSCONFDIR="@0@"'.format(
@@ -142,6 +164,13 @@ libxmlconfig = static_library(
   build_by_default : false,
 )
 
+idep_xmlconfig = declare_dependency(
+  sources : xmlpool_options_h,
+  include_directories : inc_util,
+  link_with : libxmlconfig,
+  dependencies : dep_expat,
+)
+
 if with_tests
   test(
     'u_atomic',
@@ -149,9 +178,10 @@ if with_tests
       'u_atomic_test',
       files('u_atomic_test.c'),
       include_directories : inc_common,
-      link_with : libmesa_util,
+      dependencies : idep_mesautil,
       c_args : [c_msvc_compat_args],
-    )
+    ),
+    suite : ['util'],
   )
 
   test(
@@ -162,7 +192,8 @@ if with_tests
       include_directories : inc_common,
       c_args : [c_msvc_compat_args],
       dependencies : [dep_m],
-    )
+    ),
+    suite : ['util'],
   )
 
   test(
@@ -171,14 +202,28 @@ if with_tests
       'mesa-sha1_test',
       files('mesa-sha1_test.c'),
       include_directories : inc_common,
-      link_with : libmesa_util,
+      dependencies : idep_mesautil,
       c_args : [c_msvc_compat_args],
-    )
+    ),
+    suite : ['util'],
+  )
+
+  test(
+    'bitset',
+    executable(
+       'bitset_test',
+       files('bitset_test.cpp'),
+       include_directories : inc_common,
+       dependencies : [idep_mesautil, dep_thread, dep_dl, idep_gtest],
+     ),
+     suite : ['util'],
   )
 
   subdir('tests/fast_idiv_by_const')
+  subdir('tests/fast_urem_by_const')
   subdir('tests/hash_table')
   subdir('tests/string_buffer')
+  subdir('tests/timespec')
   subdir('tests/vma')
   subdir('tests/set')
 endif