util: fix process_test path
[mesa.git] / src / util / meson.build
index 096a3d9f90245a2e4f3895e698f3142ee638e236..e30029063c0e8d81914e1c1dd47defd92d4ea788 100644 (file)
@@ -20,6 +20,7 @@
 
 inc_util = include_directories('.')
 
+subdir('format')
 subdir('xmlpool')
 
 files_mesa_util = files(
@@ -44,6 +45,7 @@ files_mesa_util = files(
   'double.h',
   'fast_idiv_by_const.c',
   'fast_idiv_by_const.h',
+  'fnv1a.h',
   'format_r11g11b10f.h',
   'format_rgb9e5.h',
   'format_srgb.h',
@@ -61,6 +63,8 @@ files_mesa_util = files(
   'os_file.c',
   'os_misc.c',
   'os_misc.h',
+  'os_socket.c',
+  'os_socket.h',
   'u_process.c',
   'u_process.h',
   'sha1/sha1.c',
@@ -84,6 +88,8 @@ files_mesa_util = files(
   'slab.h',
   'softfloat.c',
   'softfloat.h',
+  'sparse_array.c',
+  'sparse_array.h',
   'string_buffer.c',
   'string_buffer.h',
   'strndup.h',
@@ -103,12 +109,16 @@ files_mesa_util = files(
   'u_vector.h',
   'u_math.c',
   'u_math.h',
+  'u_mm.c',
+  'u_mm.h',
   'u_debug.c',
   'u_debug.h',
+  'u_debug_memory.c',
   'u_cpu_detect.c',
   'u_cpu_detect.h',
   'vma.c',
   'vma.h',
+  'xxhash.h',
 )
 
 files_drirc = files('00-mesa-defaults.conf')
@@ -147,6 +157,7 @@ deps_for_libmesa_util = [
   dep_atomic,
   dep_m,
   dep_valgrind,
+  dep_zstd,
 ]
 
 if with_platform_android
@@ -158,6 +169,7 @@ _libmesa_util = static_library(
   [files_mesa_util, format_srgb],
   include_directories : inc_common,
   dependencies : deps_for_libmesa_util,
+  link_with: libmesa_format,
   c_args : [c_msvc_compat_args, c_vis_args],
   build_by_default : false
 )
@@ -186,10 +198,8 @@ _libxmlconfig = static_library(
 )
 
 idep_xmlconfig = declare_dependency(
-  sources : xmlpool_options_h,
-  include_directories : inc_util,
+  dependencies : [idep_xmlconfig_headers, dep_expat],
   link_with : _libxmlconfig,
-  dependencies : dep_expat,
 )
 
 if with_tests
@@ -239,6 +249,7 @@ if with_tests
       dependencies : [dep_m],
     ),
     suite : ['util'],
+    should_fail : meson.get_cross_property('xfail', '').contains('roundeven'),
   )
 
   # FIXME: this test crashes on windows
@@ -267,13 +278,45 @@ if with_tests
      suite : ['util'],
   )
 
+  process_test_exe = executable(
+    'process_test',
+    files('process_test.c'),
+    include_directories : inc_common,
+    dependencies : idep_mesautil,
+    c_args : [c_msvc_compat_args],
+  )
+  if (host_machine.system() == 'windows' and cc.get_id() == 'gcc')
+    # This conversion is only required on mingw
+    process_test_exe_full_path = run_command(
+      'winepath', '-w', process_test_exe.full_path()
+    ).stdout().strip()
+  else
+    process_test_exe_full_path = process_test_exe.full_path()
+  endif
+
+  test(
+    'process',
+    process_test_exe,
+    suite : ['util'],
+    env: ['BUILD_FULL_PATH='+process_test_exe_full_path]
+  )
+
   subdir('tests/fast_idiv_by_const')
   subdir('tests/fast_urem_by_const')
   subdir('tests/hash_table')
-  subdir('tests/string_buffer')
+  if not (host_machine.system() == 'windows' and cc.get_id() == 'gcc')
+    # FIXME: These tests fail with mingw, but not with msvc.
+    subdir('tests/string_buffer')
+  endif
   if cc.has_header('sys/time.h')  # MinGW has this, but Vanilla windows doesn't
     subdir('tests/timespec')
   endif
   subdir('tests/vma')
   subdir('tests/set')
+  # FIXME: this test on the Wine version in GitLab CI
+  if host_machine.system() != 'windows'
+    subdir('tests/sparse_array')
+  endif
+  subdir('tests/format')
+  subdir('tests/vector')
 endif