util: fix process_test path
[mesa.git] / src / util / meson.build
index 66d097783cc9784e62c88f37fd00eded38004713..e30029063c0e8d81914e1c1dd47defd92d4ea788 100644 (file)
@@ -45,6 +45,7 @@ files_mesa_util = files(
   'double.h',
   'fast_idiv_by_const.c',
   'fast_idiv_by_const.h',
+  'fnv1a.h',
   'format_r11g11b10f.h',
   'format_rgb9e5.h',
   'format_srgb.h',
@@ -112,6 +113,7 @@ files_mesa_util = files(
   'u_mm.h',
   'u_debug.c',
   'u_debug.h',
+  'u_debug_memory.c',
   'u_cpu_detect.c',
   'u_cpu_detect.h',
   'vma.c',
@@ -247,6 +249,7 @@ if with_tests
       dependencies : [dep_m],
     ),
     suite : ['util'],
+    should_fail : meson.get_cross_property('xfail', '').contains('roundeven'),
   )
 
   # FIXME: this test crashes on windows
@@ -275,6 +278,29 @@ if with_tests
      suite : ['util'],
   )
 
+  process_test_exe = executable(
+    'process_test',
+    files('process_test.c'),
+    include_directories : inc_common,
+    dependencies : idep_mesautil,
+    c_args : [c_msvc_compat_args],
+  )
+  if (host_machine.system() == 'windows' and cc.get_id() == 'gcc')
+    # This conversion is only required on mingw
+    process_test_exe_full_path = run_command(
+      'winepath', '-w', process_test_exe.full_path()
+    ).stdout().strip()
+  else
+    process_test_exe_full_path = process_test_exe.full_path()
+  endif
+
+  test(
+    'process',
+    process_test_exe,
+    suite : ['util'],
+    env: ['BUILD_FULL_PATH='+process_test_exe_full_path]
+  )
+
   subdir('tests/fast_idiv_by_const')
   subdir('tests/fast_urem_by_const')
   subdir('tests/hash_table')
@@ -287,7 +313,10 @@ if with_tests
   endif
   subdir('tests/vma')
   subdir('tests/set')
-  subdir('tests/sparse_array')
+  # FIXME: this test on the Wine version in GitLab CI
+  if host_machine.system() != 'windows'
+    subdir('tests/sparse_array')
+  endif
   subdir('tests/format')
   subdir('tests/vector')
 endif