meson: Use consistent style for tests
[mesa.git] / src / util / meson.build
index 225593f5d381b486bdb2980c8816c1869a98fb19..fa591c92e5624c5e63f49f3bcb96c803ce899394 100644 (file)
@@ -118,34 +118,39 @@ libxmlconfig = static_library(
 )
 
 if with_tests
-  u_atomic_test = executable(
-    'u_atomic_test',
-    files('u_atomic_test.c'),
-    include_directories : inc_common,
-    link_with : libmesa_util,
-    c_args : [c_msvc_compat_args],
+  test(
+    'u_atomic',
+    executable(
+      'u_atomic_test',
+      files('u_atomic_test.c'),
+      include_directories : inc_common,
+      link_with : libmesa_util,
+      c_args : [c_msvc_compat_args],
+    )
   )
 
-  roundeven_test = executable(
-    'roundeven_test',
-    files('roundeven_test.c'),
-    include_directories : inc_common,
-    c_args : [c_msvc_compat_args],
-    dependencies : [dep_m],
+  test(
+    'roundeven',
+    executable(
+      'roundeven_test',
+      files('roundeven_test.c'),
+      include_directories : inc_common,
+      c_args : [c_msvc_compat_args],
+      dependencies : [dep_m],
+    )
   )
 
-  mesa_sha1_test = executable(
-    'mesa-sha1_test',
-    files('mesa-sha1_test.c'),
-    include_directories : inc_common,
-    link_with : libmesa_util,
-    c_args : [c_msvc_compat_args],
+  test(
+    'mesa-sha1',
+    executable(
+      'mesa-sha1_test',
+      files('mesa-sha1_test.c'),
+      include_directories : inc_common,
+      link_with : libmesa_util,
+      c_args : [c_msvc_compat_args],
+    )
   )
 
-  test('u_atomic', u_atomic_test)
-  test('roundeven', roundeven_test)
-  test('mesa-sha1', mesa_sha1_test)
-
   subdir('tests/hash_table')
   subdir('tests/string_buffer')
 endif